Back to overview
Resolved

Network Maintenance

Jul 28, 2026 at 6:30am UTC  –  Jul 29, 2026 at 10:30pm UTC
Affected services
Game Panel | game.tropicalhosting.net
Core Router | London, UK
RYZEN1 - EULON
PROXY1 - EULON

Resolved
Jul 29, 2026 at 10:30pm UTC

Maintenance ended

Created
Jul 28, 2026 at 6:30am UTC

We are performing scheduled maintenance to our core network infrastructure, including switching, VLAN segmentation, and internal routing. These changes are designed to improve network performance, resilience, and long-term scalability across the platform.

During the maintenance window, some services may experience brief periods of packet loss, increased latency, or temporary connectivity interruptions while network changes are applied and validated. We will restore normal service as quickly as possible and appreciate your patience while this work is completed.